1 2 3 Previous Next 32 Replies Latest reply on Nov 22, 2019 1:28 PM by AuKa_264411

    Modus Freeze

    AuKa_264411

      I have installed Modus 2.0 on a Windows 10 machine. Starts up just fine.

      I select New Application and then select the kit CY8CPROTO-062-4343W and then an application- I have tried "Hello World", TCPWM Square Wave" and "Ramping LED using Smart IO". Things seem to work as expected until about half way through- (see screen capture below) when it starts processing library files. The processing slows right down- makes working with a 1200 baud modem seem like a pleasure (yes, I am that old!).

       

      I had some patience the other day and left it- it took 2 hours to complete this task. I clicked on "Build" and the file processing froze again.

       

      Modus is installed in the default locations. I have also tried this without my anti-virus. Our network administrator says there is no data throttling or blocking.

       

      In this state Modus hogs the PC resources limiting internet access and even the 3 fingered salute (Ctl-Alt-Del) can take almost a minute to respond, if it responds at all.

       

      Has anybody else seen this behaviour, and more importantly, has anybody any idea what I am doing wrong?..

      I

        • 1. Re: Modus Freeze
          user_1669321

          Might this be the firewall?

           

          Modus tries to clone git repositories (the Cypress libraries) before building a project. Maybe try this article?

           

          Using ModusToolbox Software Behind a Firewall – KBA228784

          • 2. Re: Modus Freeze
            AuKa_264411

            That article doesn't help. My network administrator answered- 

             

            "we are not using a proxy at xxx.  We are using a firewall though, and that is why I tried disabling the content filter and other security options, to see if they were responsible for this issue; but it didn’t seem to make a difference."

             

            Anybody got another idea?

            • 3. Re: Modus Freeze
              ShipingW_81

              This looks a internet access issue. Can you please try to download the code example from github on your platform and see if there is any problem - Cypress Semiconductor Corporation · GitHub ?

              In addition, is this issue a certain case? All code examples have this issue without excaption?

              • 4. Re: Modus Freeze
                DheerajK_81

                Please try cloning a repository from Github to see if it works. Here's how you can check. If you do not already have git installed, you can download Git from here: https://git-scm.com/downloads

                 

                Once installed, open command prompt and type the following:

                git clone https://github.com/cypresssemiconductorco/mtb-example-psoc6-hello-world.git

                git_clone.png

                 

                Check if you see this on the console. If there is any error, please post it here so that we can help you further. The repository being cloned here is one of the code examples in the Cypress Github page. You cna find it here.

                 

                Also, go to Windows Firewall settings and click on "Allow an app or feature....." as shown below:

                git_clone.png

                 

                Click on "Change Settings" as shown:

                git_clone.png

                 

                Check the restrictions if any for ModusToolbox and enable access in all domain, private and public networks as shown:

                git_clone.png

                 

                Let me know if this helps and resolves your issue

                 

                Regards,

                Dheeraj

                • 5. Re: Modus Freeze
                  AuKa_264411

                  Dheeraj

                   

                  Thanks for the reply. I cloned a repository as you describe and it worked.

                   

                  I went through the Windows firewall exercise and there is NO entry for Modus Toolbox as you see below. Maybe this is a clue. To get to this I had to disable my anti-virus software (AVG)- when it was enabled Windows reported that the Windows Firewall “Allow App” was controlled by AVG.

                   

                   

                  In any event, after I cloned the repository, Modus Toolbox would load the library as expected, BUT when I clicked on “Build” it would start the process and then freeze at 20% as you can see below. Every time it freezes, I have to reboot my PC in order to get it to operate normally.

                   

                   

                   

                  So we are a little further along- what’s the next suggestion?

                  • 6. Re: Modus Freeze
                    AuKa_264411

                    Dheeraj

                     

                    I uninstalled Modus Toolbox and then disabled the anti-virus and re-installed Modus (after a machine re-boot). Modus still does not show up in the Firewall list, and the process freezes in exactly the same way after I invoke the build function.

                    • 7. Re: Modus Freeze
                      DheerajK_81

                      You can add applications directly by clicking on "Allow another app.." as shown below:

                      git_clone.png

                       

                      Click on "Browse" and point to the "ModusToolbox.exe" executable available at the path: "C:\Users\<username>\ModusToolbox\ide_2.0\eclipse". Once added, check the boxes for all networks and ModusToolbox should now work as expected.

                       

                      Regards,

                      Dheeraj

                      • 8. Re: Modus Freeze
                        AuKa_264411

                        No joy.

                         

                        It gets a bit further, and then freezes exactly as before…

                         

                         

                        • 9. Re: Modus Freeze
                          DheerajK_81

                          The ModusToolbox build infrastructure uses the GNU make to build your application. So, let's see if you are able to build the application irrespective of the IDE. Please go to "C:\Users\<username>\ModusToolbox\tools_2.0\modus-shell" and run "Cygwin.bat".

                           

                          Once opened, follow these steps to build your application using command-line interface. 

                           

                          (1) Point to the application directory where you cloned it by using the command

                          $ cd "<path to application>/mtb-example-psoc6-hello-world"

                           

                          (2) Then to import the libraries, type the command

                          make getlibs

                          You should see import complete as shown below:

                           

                          (3) Now to build the application, type

                          make build

                          The application will compile and should show "Build Complete".

                           

                          The above steps are exactly what happens when you click "Build Application" in Modus.

                           

                          Please try these steps and let me know your observations.

                           

                          Regards,

                          Dheeraj

                          • 10. Re: Modus Freeze
                            AuKa_264411

                            Dheeraj

                             

                            Nope. It freezes. See the figure

                            (P.S. to run cygwin, I had to type “.\cygwin”

                             

                            • 11. Re: Modus Freeze
                              NazarP_56

                              Hi AuKa_264411,

                              Please go to modus-shell again and provide results for following cmd:
                              1. '$PATH'
                              2. 'where git'
                              3. 'cd {to example project}

                              4. 'make getlibs VERBOSE=true'

                               

                              Regards,

                              Nazar

                              • 12. Re: Modus Freeze
                                AuKa_264411

                                Nazar

                                 

                                Given the result, I am not sure I am doing what you asked (see below). For what it is worth I spent a fair amount of time with Cypress Tech Support monitoring the actions of my machine and we still have not come to a conclsion.

                                I can tell you thatr it specific to my PC. When I try running it on a laptop (also Windows 10 with the same anti-virus, Modus Toolbox works just fine.

                                 

                                 

                                • 13. Re: Modus Freeze
                                  NazarP_56

                                  Hi AuKa_264411,
                                  per "go to modus-shell" , I mean Please go to "C:\Users\<username>\ModusToolbox\tools_2.0\modus-shell" and run "Cygwin.bat".

                                   

                                  Thanks,

                                  Nazar

                                  • 14. Re: Modus Freeze
                                    AuKa_264411

                                    This is what I get.

                                     

                                    1 2 3 Previous Next