5 Replies Latest reply on Oct 25, 2019 6:05 AM by JimT_21

    PSoC 6 Wi-Fi BT Prototyping Board DAPLINK

    NiCr_4063401

      Hi guys,

       

      I've been seeing some strange behavior on a few of my boards. The DAPLINK drive will suddenly just stop showing up. I've tried hitting SW3 for 3 seconds, unplugging, replugging, re-flashing the kp3 firmware. I just cannot get the DAPLINK drive to show up anymore with either of my two kits.

       

      Any ideas how to troubleshoot or remedy this?

       

      -Nick

        • 1. Re: PSoC 6 Wi-Fi BT Prototyping Board DAPLINK
          WangS_81

          Note you have tested different boards with same issue, it's more likely because hardware issue. What if you try another USB port or change the type-c cable?

          • 2. Re: PSoC 6 Wi-Fi BT Prototyping Board DAPLINK
            NiCr_4063401

            Thanks for the reply.

             

            I've tried a few USB ports and cables. It was working fine, I unplugged it for a bit, plugged it back in, and I've been unable to get the DAPLINK drive to show up since. This particular kit is just micro-usb, not usb c. It feels like some Windows driver type thing that got messed up, but my coworker has been seeing this on Linux as well with some of her kits.

             

            I can still program it with Cypress Programmer 2.0, but that's not as convenient.

            • 3. Re: PSoC 6 Wi-Fi BT Prototyping Board DAPLINK
              JimT_21

              I stumbled on this while hunting for general issues with KitProg and DAPLink. My apologies that this appears to have sat for a while with no resolution.

               

              1) Still a problem?

               

              2) This does sound like a Windows driver issue. Not related directly, but a similar problem was discussed here:
              PSoC Programmer stopped recognizing one KitProg3 in bulk mode . Replacing the driver resolved that (for customer and me).

               

              3) Again, although not this kit, visit the Firmware Loader site on GitHub and get the latest release. There was a "can't get into DAPLink" bug reported, and it has been fixed.

              GitHub - cypresssemiconductorco/Firmware-loader

               

              HTH!

              • 4. Re: PSoC 6 Wi-Fi BT Prototyping Board DAPLINK
                NiCr_4063401

                Hi Jim,

                 

                This is still an issue, but we have worked around it by using the Cypress Programmer tool instead of the Daplink MSD programming. We've had similar issues to the one I described across multiple operating systems with multiple kits.

                 

                With regard to the kit that I made the initial post about, I was never again able to get it to show up as a Daplink drive in any operating system. I tried reinstalling the firmware and everything. One day it just stopped working, which is quite odd I think. Some other co-workers had similar problems.

                 

                Again, we worked around the issue by just using the Cypress Programmer 2.0 directly.

                 

                -Nick

                • 5. Re: PSoC 6 Wi-Fi BT Prototyping Board DAPLINK
                  JimT_21

                  Thanks for the update Nick. I don't know that we will every figure out what's going on. I really don't like it when "stuff" just stops working. Could be anything, Since you are not blocked, it may be that we just chalk it up to "who knows."  But I will ask one of the development team to review this thread, and see if there is a low-impact (on you) way to glean useful info and maybe figure out what's going on.

                   

                  If anything comes of that, I'll post an update here. Otherwise... I don't always get to figure out everything.

                   

                  Jim