9 Replies Latest reply on Oct 3, 2019 10:43 PM by AnjanaM_61

    In HCI Mode, CYW20706 does not LE Connect

    JaPr_3925141

      Hi,

       

      We were using BlueZ to try to connect to LE Device but we kept getting the error "Connection Failed to be Established"

       

      We have attached the logs to review. Is there any sequence that has to occur to be able to connect to a LE Device in HCI Mode?

       

      2019-03-28 22:18:45.371616 < 01 0D 20 19 04 00 04 00 00 00 63 65 AE 29 6A BC 00 0F 00 0F

        00 00 00 80 0C 01 00 01 00

      2019-03-28 22:18:45.376299 > 04 0F 04 00 01 0D 20

      2019-03-28 22:18:45.810715 > 04 3E 13 01 00 40 00 00 00 63 65 AE 29 6A BC 0F 00 00 00 80

        0C 00

      2019-03-28 22:18:45.814669 < 02 40 00 07 00 03 00 04 00 02 05 02

      2019-03-28 22:18:45.934895 > 04 13 05 01 40 00 01 00

      2019-03-28 22:18:45.935244 > 04 05 04 00 40 00 3E

       

      2019-03-28 22:19:31.000127 < HCI Command: LE Create Connection (0x08|0x000d) plen 25

          bdaddr BC:6A:29:AE:65:63 type 0

          interval 4 window 4 initiator_filter 0

          own_bdaddr_type 0 min_interval 15 max_interval 15

          latency 0 supervision_to 3200 min_ce 1 max_ce 1

      2019-03-28 22:19:31.005148 > HCI Event: Command Status (0x0f) plen 4

          LE Create Connection (0x08|0x000d) status 0x00 ncmd 1

      2019-03-28 22:19:32.623672 > HCI Event: LE Meta Event (0x3e) plen 19

          LE Connection Complete

            status 0x00 handle 64, role master

            bdaddr BC:6A:29:AE:65:63 (Public)

      2019-03-28 22:19:32.628316 < ACL data: handle 64 flags 0x00 dlen 7

          ATT: MTU req (0x02)

            client rx mtu 517

      2019-03-28 22:19:32.747783 > HCI Event: Number of Completed Packets (0x13) plen 5

          handle 64 packets 1

      2019-03-28 22:19:32.748138 > HCI Event: Disconn Complete (0x05) plen 4

          status 0x00 handle 64 reason 0x3e

          Reason: Connection Failed to be Established

       

      Regards,

      Jay