1 2 Previous Next 29 Replies Latest reply on Jul 8, 2019 12:06 AM by DheerajK_81 Go to original post
      • 15. Re: Silicon ID not in database

        i get the same silicon id every time, i have two boards assembled, and 48 waiting to be assembled

        both boards have the same silicon id, clock speed is at 1.5MHz, cant go any lower

        • 16. Re: Silicon ID not in database


          could you put the part of the schema where the 5 pin connector is?

          As in your schema everything is connected to 3.3V, use the selection of 3.3V (not 1.8V).

          Have you tested with other Miniprog3? if no, do you have any prototype kit (not necessary for any P4, i.e. kit-059)?


          Note: try to reduce the capacitor in Vccd. Not sure that this is the problem, but...



          • 17. Re: Silicon ID not in database



            (Warning) a hacker style approach follows.


            I just tried to create a simple CY8C4245LQI-483 project and tried to build.

            The last 5 lines of Design01.hex was








            And the line starting with 0C has 04B61193, which is the expected silicon id of CY8C4245LQI-483.

            and the last byte 0x16 is the sum of 2's compl.


            So I wonder if you copy and make the backup of the hex file and modify the line from





            We may be able to fool the PSoC Programmer.

            I'm afraid that this is NOT a recommended method though.


            And in case this does not work, please don't get mad at me.



            • 18. Re: Silicon ID not in database

              i have 049 and 059 kits, tried programming it with part of 059 kit, same error


              mine line is :0C000000000204B61193110004D0DF2DA3 ,bit different from yours

              metadata is then corrupted...

              i was going in the same way, then tried editing database file, nothing

              then found out that PSoC Programmer uses programming algorithm file to know exactly what to to

              so editing CY8C42xx.FLM file could be helpful, if anyone knows how to do it

              • 19. Re: Silicon ID not in database


                if you use Kit-059 (to be exact, the Kitprog -  the small board with USB "pcb connector"-) you can only program with "Reset". "Power Cycle" isn't supported. So, you need to have your board previously powered and to have connected XRES


                Sorry, but, are you sure that your connections are correct (between your board and the miniprog / kit )?


                Note. In the document of Programming Specifications previously linked, after the 4 bytes than identify the chip, next 6 bytes are: 2 reserved and last 4 are internal (used by Programmer only).

                More "hacking" . I think that the file that have the identification is "CY8C4xxx.dat", located in "..\Programmer\Devices"

                copy the file (to have a original in safe place"; look for the line with CY8C4245LQI-483 and replace, with the same format, the ID that you have.

                I'm not sure that this works, it's dangerous, etc,etc.

                I repeat, I've more the feeling that something HW is the problem.




                • 20. Re: Silicon ID not in database

                  How long are the wires connecting the Miniprog3 5-pin connector to the pcb?  People have found issues when wire-length is over 4.5" (~11.5cm).


                  Also, do you:

                  1) connect Miniprog3 to pcb

                  2) power the target up first

                  3) and then plug Miniprog3 into PC

                  The above sequence is used so that Miniprog3 will not try to apply power to the target pcb.  Miniprog3 will detect the voltage at the SWD interface.  See FAQ #8 here:

                  Troubleshooting PSoC® 3/4/5LP Programming/Debugging Issues - KBA210619


                  I would connect XRES from target to Miniprog3 and select RESET in Programming Mode.


                  Most people have success using the 5-pin connector to Miniprog3.  Usually, nobody has success using the 10-pin connector.  It's a long shot, but can you try the 10-pin connector?



                  • 21. Re: Silicon ID not in database



                    A couple of primitive questions came to my mind.


                    (1) What are the letters written on your device (marking)?

                        May be, with that information Cypress people can identify the device and its lot.


                    (2) From whom did you purchased the device(s)?

                        If they are an authorized distributor, you may be able to ask the replacement

                       in case the silicon ID is really wrong.

                       Or may be you can just order a few of these from DigiKey or similar distributor.

                       And check if the silicon ID is the same or different. (I'm afraid that this add some more cost though)



                    • 22. Re: Silicon ID not in database

                      In addition to the "marking"  please take a picture of the chip surface.




                      • 23. Re: Silicon ID not in database

                        im sure connections are correct, tried editing dat file, didnt help


                        wires are 7-8cm, im powering chip using programmer, couldnt connect it using 10-pin connector


                        markings on the chips are:

                        CY8C4245          CY8C4245

                        LQI-483               LQI-483

                        1625 8 04           1625 8 03

                        CYP623686       CYP645064

                        PH1 OC             PH1 OC

                        116                     058


                        cant focus camera on such a small surface


                        chips are not bought from official distributor, because of shipping

                        official distributors send via couriers (DHL,UPS), and all packages go trough customs,

                        and here, you cant legally import more than 3 psc of something

                        (found out that the hard way, they took my first shipment)

                        but when sent via ordinary post, you can import anything, nobody opens the packages

                        • 24. Re: Silicon ID not in database



                          Thank you very much for your taking pain of copying those marking data.


                          Although I have no clue about the details, I hope that Cypress Folks can look up the information.


                          Also I'm very sorry for hearing "(found out that the hard way, they took my first shipment)".



                          • 25. Re: Silicon ID not in database



                            I just tried to open

                              C:\Program Files (x86)\Cypress\Programmer\Devices\CY8C4xxx.dat

                            with my text editor.


                            The line 25. reads

                              2,CY8C4245LQI-483, CY8C4245LQI-483, 40, 32768, 3, 04_B6_11_93, 04_B6_12_93, v33


                            May be we can try changing it to

                              2,CY8C4245LQI-483, CY8C4245LQI-483, 40, 32768, 3, 00_00_21_93, 04_B6_12_93, v33



                            P.S. Please backup the original just in case.

                            • 26. Re: Silicon ID not in database

                              tried it before, didnt work

                              i think only editing CY8C42xx.FLM would help

                              • 27. Re: Silicon ID not in database



                                > tried it before, didnt work

                                I'm sorry for my yet another useless post.


                                > i think only editing CY8C42xx.FLM would help

                                I took a look at the file, it's Keil compiled binary file and something not quite easy to correctly modify,

                                unless you have the source code.


                                Although in these few days I've been trying to find a way to workaround,

                                I'm getting more and more suspicious feeling the the device you are working on

                                may not be "CY8C4245LQI-483"


                                Once I have heard a story about one of our customers who purchased device from an "un"-authorized Chinese dealer.

                                The device and its marking seems to be correct, but the product built with that device did not work.

                                After all when they used x-ray, they found that there was no "silicon" in that package.


                                This time, at least you can read out some ID, so your device surly has some silicon though. 


                                BTW, I'm just curious but as you posted two different markings

                                > 1625 8 04        1625 8 03

                                > CYP623686       CYP645064

                                Have you tried both types?


                                I think that currently there are two possibilities

                                (1) Your board and/or environment have some problem that prevent you from reading out correct ID from correct device.

                                (2) Unfortunately we have been trying to make bogus device(s) to work



                                • 28. Re: Silicon ID not in database

                                  Sorry, but I think you have a device with wrong silicon id. Please contact your distributor to provide you a replacement.




                                  • 29. Re: Silicon ID not in database

                                    Can you please change your design based on Page#6 in the hardware design guide?


                                    Please refer to this KBA for more information: Silicon ID Mismatch while Programming PSoC® Devices - KBA221305


                                    If it still fails, then you have a faulty silicon and you need to get a replacement.




                                    1 2 Previous Next