7 Replies Latest reply on Apr 23, 2019 9:33 PM by RajathB_01

    CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)


      Hello All,


      I have CY4532 Evaluation Kit and trying to debug using "CYPD3171-24LQXQ_pb01.cyprj" sample project.

      Observed that the Device is not detected when i trying to connect to the Target by selecting the option present in the IDE as mentioned below.


      Debug ----->  Select Debug Targer ----> Show All Targert


      After that if I click "Port Acquire" in "Select Debug Target" Window throwing below error..


      "There was an error running Port acquire: Can not acquire SWD device!"


      I tried searched for document reference to see am i missing anything here, but i could not find any information.


      If any one succeeded in using CCG3PA in the debug mode using MiniProg3 please share the procedure to do the same.


      Thanks & Best Regards,


        • 1. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

          Hi Krishna,


          Please make sure the SWD settings are as follows by clicking on 'port setting'

          Annotation 2019-04-02 101111.png


          Click on OK and then choose Port Aquire.


          You should be able to see the CCG3PA controller detected as below. Double click on it to connect.


          Annotation 2019-04-02 101447.png


          Also make sure the main board has jumper J6 set to short pins 2 and 3 (VDDD - VTARG).




          • 2. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

            Hi Rajath,


            Thanks for your answer, i was able to detect the device and connect to board. But after debugging found that the device is no more responding to PA/PB modes. I Followed below mentioned procedure to achieve the same.


            (1) I tried to run noboot project available in the sample project, after running the code, CCG3PA power LED goes off and none of the feature works.Following jumper settings are made on the board.

            Main Board(CCG3PA):

            Jumpers J2, J3, J4 and J6 are shorted to pin number 1-2

            Jumpers J5 and J7 are open.


            Power Board

            Jumper J6, J7, J9 and J14 are short to pin 1-2.



            (2) Trying to update the firmware using SWD Miniprog3 as mentioned in the below link, in Firmware update starts by giving Busy status but and then Fail.I followed the instruction in described in the below link.



            I tried on two different units of CCG3PA, now i am not able to use both of them as Adapter.

            Looks Firmware i getting corrupted when I tried to debug using MiniProg3.

            I am not able to find out what is the reason.


            Best Regards,


            • 3. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

              Hi Krishna,


              You should be able to re-flash the default bootloader (provided with SDK) onto CCG3PA using miniprog3 over SWD.

              Use the noboot project only for debugging the code. For testing all the features you may need to disable BREAK_AT_MAIN macro so that entry into main is not restricted.


              Also, can you please specify what exactly is the error seen after unsuccessful firmware update?




              • 4. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

                Hi Rajath,


                Thanks for the response.

                That was my mistake that i was selecting CY3175 hex file instead of 3171.

                With correct hex file it worked.

                Using CCG3PA is there any project available with all the Features such as PA, PB and BC1.2 in project?

                I want to develop one with all the feature available in the single firmware how do i achieve this? Is there any document available?


                Best Regards,


                • 5. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

                  Hi Krishna,


                  Power Bank (PB) is like a superset which can also perform charging like a Power Adapter (PA). The PB firmware also does BC1.2, AFC, QC and Apple Charging for legacy devices.

                  So you will not need to think of implementing PA feature in a PB firmware.

                  The reason we are giving a seperate PA firmware is to off-load some redundant and unnecessary code + features since the hardware for a power adapter will be much simpler.

                  In fact, I'd like to say that the combined firmware you are looking for is the PB firmware itself.


                  Probably the biggest concern would be the maximum power output of the PB system. In a PA system, you can easily draw the PD limit of 100W off a wall socket. But doing the same with a battery is not easy (and not cheap). But functionality-wise, PB will be able to do everything you are asking for.




                  • 6. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

                    Hi Rajath, I am trying to test the features CCG3PA EVK Board and facing the following issues:


                    1. In configuration utility, I am unable to detect UFP-AMA, tried the possible solutions and also tried Frequently Asked Questions on CY4532 CCG3PA Kit – KBA226613 the method mentioned in this document, still unable to detect UFP-AMA.


                    2.I observed CC1 and CC2 voltages as 0.132v on each pin and concluded that EVK board has PB FW as mentioned in Evalution kit guide section-C and when I connect a provider/source device to the J10 port and battery to J1 terminal than power contract is done and battery is getting charged but when connected a consumer to the J10 port and J9 port, No Power contract happened and unable to charge the connected devices to J10 and J9 ports.


                    3.I have not observed LED1 glow in any mode while performing operations.


                    Am I missing any points, Thanks in advance.


                    Best Regards,


                    • 7. Re: CY4532 EZPD (CCG3PA) Debugging using MiniProg3(SWD, 5wire)

                      Hi Pranay,


                      Please open a new thread for this, as it seems to be a different issue altogether and it will help other community users locate such content.

                      Mention the EVK version and the battery being used in that thread.

                      Locking this thread.