2 Replies Latest reply on Jan 5, 2019 2:36 PM by james.long_3965396

    CY8CKIT-059 USBUART Will Not Initialize.


      I'm using CY8CKIT-059 and am attempting to get the USBUART working - preferably including powering the device.


      However, in the example code, there is a wait for " USBUART_GetConfiguration() that will wait until that returns a non zero value. It always returns 0.

      I've tried the examples, I've verified my clocks.. Code compiles, and programs no problem.


      I've got a regular TTL UART working, but I'd much rather use the USB uart so I can have just the one cable running to this module for power and communications...


      FYI This doesn't appear to be a windows device issue - it doesn't enumerate because it is stuck in that loop of GetConfiguration.


      I've also tried it on two seperate CY8CKit's...



      int main ()




          /* Start USBFS operation with 5-V operation. */





              /* Host can send double SET_INTERFACE request. */

              if (0u != USBUART_IsConfigurationChanged())  // THIS ALWAYS RETURNS 0


                  /* Initialize IN endpoints when device is configured. */

                  if (0u != USBUART_GetConfiguration())  // THIS ALSO ALWAYS RETURNS 0


                      /* Enumeration is done, enable OUT endpoint to receive data

                       * from host. */






      I can get by using an external TTL to USB Serial adapter, but that kinda defeats the purpose Any help would be greatly appreciated..