8 Replies Latest reply on Jan 15, 2019 1:17 AM by sajoc_1338106

    miniprog3 arm debug port

    sajoc_1338106

      I am unable to program PSoC 5lp. I could see both the LEDs(Red-target supply and Green- Status) are ON. When I acquire the port, I am getting "ARM DEBUG PORT"(Screen shot attached) INSTEAD OF PSoC 5lp. Kindly let me know how to determine what is wrong. Appreciate any assistance.

        • 2. Re: miniprog3 arm debug port
          RyanZ_36

          Hi Santhosh,

           

          A DVK or your own board are you playing?

          Suggest double-checking the hardware connection(power domain, switch...), port settings(voltage level, programming mode...).

          are the SWD ports required by other tool?

          A KBA about programming issue is FYI:

          Troubleshooting PSoC® 3/4/5LP Programming/Debugging Issues - KBA210619

           

          Thanks,

          Ryan

          • 3. Re: miniprog3 arm debug port
            sajoc_1338106

            Hi Ryan,

             

            It is a custom PSoC board. I was able to program it with Kitprog

            successfully. Issue is with the miniprog3.

            • 4. Re: miniprog3 arm debug port
              sajoc_1338106

              Hi Ryan,

               

              I have gone through the link. I checked the community threads as well. But I am unable to find any description of the issue or a solution.

               

              Hi All,

               

              Any workaround or solutions, please let me know.

              • 5. Re: miniprog3 arm debug port
                JoMe_264151

                Did you already try to update the miniprog3 to latest revivion using PSoC Programmer?

                 

                Bob

                • 6. Re: miniprog3 arm debug port
                  sajoc_1338106

                  Dear Bob,

                   

                  Yes, I updated the miniprog3 but I am unable to program.

                  Kindly find the log below. Appreciate your help.

                  "

                  Program Finished at 02:59:56                                |

                                                                               

                  FAILED!

                  Cannot halt CPU and activate Debug

                   

                  Please, check

                  the following items:

                   

                  - the

                  connection between the programmer and the PSoC;

                   

                  - the

                  correct programming protocol is selected;

                   

                  - the

                  correct connector option is selected.

                  Program Requested at 02:59:53

                                                                               

                  MiniProg3

                  version 2.05

                  Firmware Update Finished at 02:59:46

                                                                               

                  FAILED! FW

                  Version is up-to-date. No need of Upgrade. Hex: 2.05 MiniProg3: 2.05

                   

                  Initializing...

                  Firmware Upgrade Started at 02:59:46                        |

                  Firmware Upgrade Requested at 02:59:45                      |

                  Successfully Connected to MiniProg3/1609BB000FEF at 02:58:44 | MiniProg3

                  version 2.05

                  Opening Port at 02:58:43                                    |

                  Memory Types Load from HEX Finished at 02:58:43              |

                  Device set to CY8C5868AXI-LP035 at 02:58:43                  | 262144

                  FLASH bytes

                  Device Family set to CY8C5xxxLP at 02:58:42                  |

                  Memory Types Load from HEX Requested at 02:58:41            |

                  Active HEX file set at 02:58:41                              |

                  E:\Users\CUSE\Documents\PSoC

                  Creator\Workspace04\BOOST_testing_New_board.cydsn\CortexM3\ARM_GCC_541\Debug\BOOST_testing_New_board.hex

                                                                              |

                                                                              | Users must be

                  aware that the following PSoC device should not be powered or programmed at

                  5V. Doing so will cause damage to the devices: CY8C6xxx, CYRF89xxx

                  Session Started at 02:58:41                                  | PPCOM

                  Version 29.0

                   

                  "

                   

                   

                  On Sun, Dec 23, 2018 at 2:57 AM user_1377889 <community-manager@cypress.com>

                  • 7. Re: miniprog3 arm debug port
                    RyanZ_36

                    Could you double-check the hardware connection of PSoC5 and MiniProg-3? Use programming cable as short as possible. 

                    Are there any other silicons on your board? MiniProg-3 has limited current sourcing strength.

                    Double-check VDDD, VDDA, VDDIO, VCCD...is connected correctly.

                     

                    Thanks,

                    Ryan

                    • 8. Re: miniprog3 arm debug port
                      sajoc_1338106

                      Dear Ryan,

                       

                      Appreciate your assistance.

                      I checked the voltage levels and the also used the provided 10-pin

                      connector but getting the same error. But I am able to program it

                      successfully with PSOC 5lp CY8CKIT_059 successfully.