4 Replies Latest reply on Dec 5, 2018 4:10 AM by EyGe_3183606

    CyBle_StoreBondingData gets FIXED STACK BOOTLOADER stuck on startup




      I am using PSOC 4 BLE (4.2).

      I have been using the Fixed Stack bootloader project for quite some time now with our bootloadable application and everything has been working fine.

      Recently, we added the feature of bonding to the bootloadable application and also added the saving of the bonding data to the flash using the cypress API CyBle_StoreBondingData.

      We see that whenever the bonding data is stored using that API then if we perform a reset to the device, it loads and gets stuck within the function Bootloader_Start() and doesn't respond anymore.

      If we erase that single line (CyBle_StoreBondingData) from the bootloadable application then everything works fine.

      We tried using both CyBle_StoreBondingData(1u) and also CyBle_StoreBondingData(0u) and both provoke the same result.

      What should we do? We still want to save the bonding data to the flash but if the bootloader gets stuck after reset, it is a huge problem.

      What should we do?