2 Replies Latest reply on Oct 30, 2018 2:27 AM by tingc_3819211

    S6ECC-ETH uVision5 debugger support for virtual machine

    tingc_3819211

      Hi all,

       

      I just bought the FM4-176L-S6E2CC-ETH Pioneer Kit and having issues trying to setup an IDE using Keil uVision 5 which I really hope someone could guide me through. The issue is I cannot program/debug it eventhough I have connected to the board and run pre-defined tests via a serial terminal.

       

      Moreover, since this is related to multiple sectors, it is appreciated if you could provide insight with different approaches for this matter, i.e. maybe this is an issue with the IDE, virtual machine limitation, et cetera.

       

      Background:

      + I'm using Windows 7x86 (32-bit) virtualized on a macOS High Sierra.

      + I followed the Jumper Despcription inside the board schematic from Cypress product page

           - J4: 1-2 Power form CN2

           - J3: 2-3 Flash Programming via USB

           - J1, J2: Open

       

      + The Keil uVision5 setup was tried from 3 sources and neither of them work

           - The S6E2CC Kit Quick Start Guide

           - The S6E2CC Project Template from Cypress product page

           - Laboratory Manual from ARM University Lab-in-a-box package which also using the same kit

       

       

      Specifically, the connection indicated from Device Manager

      Screen Shot 2018-10-27 at 10.32.19 PM.png

       

      Also, running tests from a 3rd party serial terminal successfully (for some reason the provided terminal did not work for me, i.e. opened then disappeared, although still running from background and was detected by Task Manager).

      Screen Shot 2018-10-27 at 10.33.34 PM.png

       

      However, the setting in Options for Target <name> -> Debug -> CMSIS-DAP Debugger <Settings> are all blurred out (cannot select) without any indication of Debug Unit in detected JTAG device chain as well as when I chose Port: SW.

      Screen Shot 2018-10-27 at 10.34.38 PM.png

       

      For more information, this is the Programming Algorithm was chosen and the CMSIS-DAP firmware version of the board.

      Screen Shot 2018-10-27 at 10.34.46 PM.pngScreen Shot 2018-10-27 at 10.56.40 PM.png

       

       

      Needless to say I have tried many different approaches and am considering to flash the J-Link firmware into the MB9AF312K, the details are in this question Development Environment Setup - DAP Device Not found. However, before I do that and permanently alter the original firmware, I would like to seek the helps from this communitiy first.

       

      Thank you,

      Tin Nguyen