1 Reply Latest reply on Oct 13, 2017 2:55 AM by nishanta_46

    JTAG debugging on CX3

      I have an e-Con Ascella dev board which has a CX3 on it.  I'm able to flash code to the board, but am unable to get the debugger to connect.  I've followed the steps in the EZ USB Suite Users Guide, section 3.1, "Debugging using Segger J-Link", as well as section 3.2, "Debugging with OpenOCD".  Neither of these configurations will successfully connect to the board.

      -  I have the board in "USB Mode", so that USB Control Center sees the board as "Cypress FX3 USB BootLoader Device".

      - The debug USB port is also plugged in and comes up as USB-Serial (Dual Channel) Vendor 1.

      - I've tried to update to the latest version of OpenOCD (version 0.10.0), but no difference other than better error messages.

      - I've tried to start OpenOCD manually rather than through Eclipse, but it says - "Error: The specified debug interface was not found (cy7c65215)"

      - I've tried a different OpenOCD config file as suggested here - JTAG Debugging over USB Serial

      - When I tried the Segger J-Link configuration, it says "No emulators connected via USB"


      What is the proper way to invoke the debugger on this platform?