10 Replies Latest reply on Nov 3, 2017 5:50 AM by hotoc_2798536

    Autocomplete function not working.

      Good day.


      A weired problem regarding autocompletion here:

      I got 2 laptops and running PSoC Creator 4.1 in same VM config (virtualbox 5.1.22)

      on both machinces. However, the autocompletion function works not at all in

      one of them, even I have all options checked in

      [Tools]->[Options]->[Text Editor]->[Inline_Diagnostics and Autocomplete].


      I tried to (all in the VM) remove guest addons, w/ or w/o D3D support,

      upgrade to 5.1.26 or uninstall then reinstall back 5.1.22, all efforts in vain.

      The other one kept in 5.1.22 still has autocompletion functioned perfect.

      If anyone has ever encounter similar problem and/or know any clue to it,

      please kindly let me know.




        • 1. Re: Autocomplete function not working.

          Have you tried reinstalling PSoC Creator4.1

          • 2. Re: Autocomplete function not working.

            Yes, uninstall, reboot, then reinstall, reboot. The problem remains after that.

            Now I got both setups (2 VMs in the opening post) having this issue,

            even after another current VM version (5.1.28).


            BTW I have tried guest addon on and off, d3d support normal (win7 aero support) and

            basic (win7 aero not support).


            I've noticed that the once being normal one started being abnormal after a VM crash.

            However, I cannot do anything to that even a completely project rebuild (clean and build

            all project within).


            Is there still anything I missed and should try as well? Tried every config I could imagine

            and got nothing is quite frustrating..


            **Edit: 20170920-0957**

            Just found someone had autocomplete dysfunction in the forum as well, though he

            still got something to display, instead of nothing out in my case:

            PSoC Creator 4.1: Code editor / AutoComplete feature not showing all contens

            • 3. Re: Autocomplete function not working.

              One of the following Windows platforms is required:

               Windows 7 and Windows 7 SP1 (32- and 64-bit supported)

               Windows 8 and Windows 8.1 (32- and 64-bit supported)

               Windows 10 (32- and 64-bit supported)

               Mac OS X El Capitan on VMware Fusion 8 running Windows 8.1

               Mac OS X El Capitan on Parallels Desktop 11 running Windows 10

               Ubuntu 15 Linux with Oracle VM VirtualBox running Windows 10

              • 4. Re: Autocomplete function not working.

                anks, thanks for the prompt replying,


                Excuse me for not being clear enough in environment specification:

                I am currently running Windows 7 SP1 64-bit up-to-date in Oracle (VM) VBoxs, in Windows 7 SP1 64-bit up-to-date host, over 2 laptops.

                Each of both laptop have 4GB (VM) / 16GB (physical) RAM.


                Other version information had been informed in previous posts.


                If there's something missed, that might help identifying problems, please tell me.

                • 5. Re: Autocomplete function not working.

                  When using any virtual machine environment, Parallels or

                  Fusion, the more RAM you have on the system the better!!

                  This may be useful-


                  Programming Problems with Virtualization (VMWare, Parallels) on MacOS

                  • 6. Re: Autocomplete function not working.

                    When the semantic parsing option was  enabled , what value is set in  "macro filtering" section

                    • 7. Re: Autocomplete function not working.

                      Thanks PSBU_2325551, for the info. However, I have no usb programming problem.


                      AnkitaS_51, here's my setting window. Except "Show all", I have tried "Show all except system defines", "Show marco-functions only", and nothing will jump up. E.g. typing "UART" in any lines within "int main () {" and "}" will not get any small selecting window pop up like it used to be, even I have put an UART block and rebuilt without an error:

                      PSoC_Creator_4.1-Tools-Options-Text Editor-Inline_Diagnostics and Autocomplete.jpg


                      I have even tried using some example project / workspaces, they just couldn't make autocomplete pop up,

                      so I think the probability of troublesome project codes is ruled out.


                      I never went back to try 4.0..maybe when I have more free time.


                      BTW, is it possible that the newest version of creator 4.1

                      has some kind of conflict with virtualbox versions at least from 5.1.22 up to 5.1.28?

                      • 8. Re: Autocomplete function not working.

                        MMmm..maybe it's really a problem in 4.1?


                        Just install 4.0 update 1 back to my VB, and voila! Autocomplete functioned well in this old version. Check the pics below, while I tried to using the same example workspace "SCB_Bootloader" which is for CY8CKIT-049. The code showed here is the main.c within project "Bootloadable Blinking LED". Have rebuilt in 4.0, and then updated components and rebuilt in 4.1:


                        vvvv Creator 4.0, autocomplete normal.



                        vvvv Creator 4.1, no autocomplete.



                        The autocomplete is turned on in both versions of Creators. Any thoughts?

                        Would Cypress guys help me out of it, or do I have to turn back to 4.0?

                        • 9. Re: Autocomplete function not working.

                          I have install a copy of creator 4.1 update 1 in my host OS: win7 x64 sp1, and the auto completion is working well. Don't know why it hates virtual environment so much. 4.0 used to be good..


                          Too bad..the ability, that keeps these enormous IDE suite in a simplified client environment and lowering the needs for maintaining the host from too much software/drivers installed, is and always will be welcomed feature, at least to me.

                          • 10. Re: Autocomplete function not working.


                            I also have the same situation that Auto Complete do not working in version 4.1

                            I found that in PSoC Creator 4.1 there is a library name >libclang.dll< installed in the bin directory. I just copy and replace that from version 4.0, so when I restart the PSoC Creator 4.1 again, the Auto Complete working well.!


                            The interested thing is that in previous version the >libclang.dll< file has just around 4MB size but in version 4.1 it has around 40MB!!