10 Replies Latest reply on May 29, 2015 9:23 AM by andrew.lukin_cogniance

    factory_reset_dct not working




      are you planning to fix make files for factory_reset_dct? Is this functionality depracated? How should we generate a factory DCT?


      Kind regards,


        • 1. Re: factory_reset_dct not working



          For factory reset please take a look at the snip app .../apps/snip/ota_fr.


          * Perform factory reset on the WICED evaluation board

          *   To perform factory reset on the WICED evaluation board, work through the following steps:

          *   - Push and hold the SW1 button THEN momentarily press and release the Reset button.

          *     The D1 LED flashes quickly to indicate factory reset will occur *IF* SW1 is held

          *     for a further 5 seconds. Continue to hold SW1.

          *   - After the copy process is complete, the WICED evaluation board reboots and runs the factory

          *     reset (OTA_FR) application. Observe the log messages at the terminal to confirm the factory reset

          *     is completed successfully.



          • 2. Re: factory_reset_dct not working



            we are trying to generate factory reset dct image. Something that once worked with dct_factory_reset  make parameter.



                Generates a factory reset DCT


            Kind regards,


            • 3. Re: factory_reset_dct not working


              A factory reset DCT can be created by setting the make variable DCT_IMAGE. This will set the DCT image that will be loaded in to the external flash and reloaded in factory reset. For more details have a look at





              • 4. Re: factory_reset_dct not working

                The procedure documented in "3.2 Generating DCT Images" is no longer working in SDK 3.2 and a "make factory_reset_dct" fails with "no rule" error.


                How do you suggest we generate these files? I can see there is a "make" DCT_IMAGE variable supported in the application makefile but how would that work if we need thousands of different DCTs? Is the factory_reset_dct.c template still to be used?



                • 5. Re: factory_reset_dct not working

                  Have a look at apps/snip/ota_fr/ota_fr.mk, the DCT is set in the same way as factory reset application. By setting the DCT_IMAGE parameter.


                  When building your factory reset application, the DCT should be created as well and you can point to it.


                  Hope this answers your question.




                  • 6. Re: factory_reset_dct not working

                    I am sorry if I didn't explain myself correctly. I can create one DCT

                    fine by adding the DCT_IMAGE parameter in the makefile. However, this is

                    not the way to make one thousand different DCTs to use in production. In

                    SDK 2.x there was a factory_reset_dct.c file with dynamic keywords and then

                    replaced with values from text files to generate appropriate binaries. This

                    is documented in chapter 3 of the "Factory Programming" document. Can

                    someone from Broadcom please explain how to do the same with SDK 3.x?



                    • 7. Re: factory_reset_dct not working

                      The reason factory_reset_dct target fails is probably because wiced_factory_reset.mk file is missing from the SDK. It's included from the Makefile, but is nowhere to be found in the 3.x source tree, even though it's clearly present in 2.4.0.

                      • 8. Re: factory_reset_dct not working

                        We have never made it work. Finally, we had to abort the migration to the 3.x.x. Eventough, will be useful to know how to generate DCTs to use in production.

                        • 9. Re: factory_reset_dct not working

                          @alexb, @mat3y


                          Thank you for your useful comments. I also tried to make it work based on your comment but so far no luck.

                          Perhaps someone from Broadcom should provide a solution.

                          • 10. Re: factory_reset_dct not working


                            I faced the same problem.


                            I've updated 2.4's wiced_factory_reset.mk to use in 3.1.2

                            Some modifications to the main Makefile required as well.


                            Please see files attached.

                            Looks like it works now.