9 Replies Latest reply on Jan 5, 2012 8:27 AM by HeLi_263931

    Unable to register PSoC

      I am unable to register PSoC creator tool.Everytime i provide my login credentials,a message in red appears as shown in the screen shot.

        • 1. Re: Unable to register PSoC



          Are you connected to the internet while registering in PSoC Creator?


          The error message seems to indicate that there is an issue with the network.


          Let us know about this.







          • 2. Re: Unable to register PSoC





            i have exacly the same problem.


            Tried few times from few totally different networks with no luck.


            My internet connection is working for sure and non ports are blocked.




            When i did dump with Wireshark i can see that i receiving (from  


            "HTTP 686 HTTP/1.1 500 Internal Server Error (text/html)"


            If it would be helpfull i can send hole network dump during registration process (.pcap).




            Thanks in advance for reply,


            best regards

            • 3. Re: Unable to register PSoC

              I have the exact same issue.  Network is up and running.  I can browse the cypress web site with no problem. Just can't register PSOC creator.


              System is XP Pro Service Pack 3.

              • 4. Re: Unable to register PSoC

                 Me toom very frustrating it wont register Keil properly either.


                I'm using windows 7.

                • 5. Re: Unable to register PSoC

                  Here also... Vista Ultimate


                  My other tools like Altium and stuff which send bs back and forth on execution work fine as well as a ton of other network stuff.





                  • 6. Re: Unable to register PSoC

                    Same problem here (W7/64bit). I tried it at work and at home, but without success. Registration of Keil worked, though. According to netstat, the creator tries to connect to some Akamai-Instance:


                      TCP     a62-214-9-151.deploy.akamaitechnologies.com:http  ESTABLISHED
                      TCP     a62-214-9-151.deploy.akamaitechnologies.com:http  ESTABLISHED




                    Btw: the dialog pops up every time I open the creator, even if I select "don't display at startup".

                    • 7. Re: Unable to register PSoC

                      Same problem. Does anyone from Cypress monitor this Forum?

                      • 8. Re: Unable to register PSoC





                        first of all my apologies for the problems you all are having during registration. Cypress does monitor this and all other Cypress forums. For your issue "unable to register Creator" there can be multiple reasons. The best option is to file a specific support case with Cypress Tech Support


                        Go here: www.cypress.com/go/support


                        Center Window lower left corner "Create a case" is the way to go. You will be contacted through our support team and they will handle your specific issue.


                        Obviously this is an issue because several people have similar problems. There are many thousands Creator installations out there and 99.xx% work without that issue, it is our goal to approach the 100% with your help.


                        If you check this thread, there were 4 people in 8 months but there have been 3 more in just 9 days, it appears that Creator 2.0 installations are more susceptible to this problem. Please work with tech support and if we find a common problem we will publish here on the forum.


                        @ hli, it is correct that we are using akamai to make downloads faster. The difference is huge in some countries and noticeable in some others.


                        All, if you are posting a problem here in the forum, please provide as much information as possible.

                        1. Which OS (specific like wavelength and hli did it)

                        3. Have you used an earlier version of Creator successfully before?

                        5. Error message

                        7. The hardware you are using, host and target if applicable

                        9. Any messages you get while you try to register.


                        Thank you for your patience and coming forward so that we can help many users.



                        • 9. Re: Unable to register PSoC

                          I opened a case, and just had a nice phone call with Cypress support. The resolution was to disable this dialog ('dont display at startup'). They told me that PSoC creator will be fully functional in this case too (I already registered Keil which was the important part).