Compatibility of ISD-300 with Mass-storage Class

Question: Does the ISD-300 need a custom driver to work, or is it mass-storage class compliant?

 

Answer:

The ISD-300 is mass-storage class compliant and does not necessarily need the ISD drivers to operate correctly. All ISD-300 products should work with the Microsoft or Apple mass-storage drivers.

Please note that the ISD-300 is obsolete and the functional replacement is AT2LP.  All the related collaterals of AT2LP can be found in the link here