ModusToolbox 2.2をインストール後、ModusToolbox 2.1でEclispe IDEを使用 – KBA231606 - Community Translated (JA)

Version 3

    Community Translated by keni_4440091    Version: **

     

    Translation - English: Using Eclipse IDE for ModusToolbox 2.1 after Installing ModusToolbox 2.2 - KBA231606

     

    質問: ModusToolbox 2.2をインストールした後、ModusToolbox 2.1をインストールしたEclipse IDEを使用してプログラムまたはデバッグを実行している時に何故エラーが出ますか?

     

    コマンド:[PATH]/ModusToolbox/tools_2.2/CY_TOOL_arm-none-eabi-gdb_EXE --versionを実行中のエラー

     

    回答: 初期設定では、ModusToolboxはインストールツールの最新版を使用します。今回の場合、バージョン2.1および2.2がインストールされているので、ビルドシステムはツールのバージョン2.2を使用しています。この問題を解決するためには以下のどちらかを行ってください。

     

    オプション1ModusToolbox 2.2でインストールしたEclips IDEを使用して、対応するワークスペース/アプリケーションを開きます。

     

    オプション2:パスを“tools_2.1”ディレクトリに更新します。正しいパスを指すためにCY_TOOLS_PATHSシステム変数を作成します。詳細は、ModusToolbox Installation Guide,"Create a system variable to specify the path to Tools."の章を参照してください。そうするとModusToolbox 2.1でインストールしたアプリケーションEclips IDEを開くことができます。