「有効なCySmartドングルではありません!」CySmart C#API使用時のエラー - KBA231268 - Community Translated (JA)

Version 1

    Community Translated by NoTa_4591161 Expert     Version: **

     

    Translation - English: “Not a valid CySmart dongle!” error when using CySmart C# APIs - KBA231268

     

    質問:

    CySmart APIを使用してC#でアプリケーションを作成しています。TryGetCySmartDongleCommunicator APIを使用してCySmartドングルと通信すると、「Not a valid CySmart dongle有効なCySmartドングルではありません)」というエラーが表示されます。 このエラーを回避するにはどうすればよろしいでしょうか?

     

    回答:

    CySmartソフトウェアは、追加された新しいドングルサポートのためにアップデートを定期的に受け取ります。このエラーは、C#アプリケーションが新しいデバイスを認識しないで古いDLLを使用しているために発生します。

    次の手順に従って、アプリケーションを最新のDLLに更新します。

    1. 最新のCySmartソフトウェアをインストールします。
    2. Visual StudioC#アプリケーションを開きます。
    3. ソリューションエクスプローラウィンドウで、次のようにプロジェクトの[ References ]セクションを開きます:
       
    4. すべてのCySmart DLLを右クリックし、[ Remove ]をクリックします。 
    5. References > Add Reference > Browse を右クリックします。次のパスから最新のDLLを追加します:「C:\Program Files (x86)\Cypress\CySmart\1.x\bin」(xは最新のマイナーバージョンです)。
    6. [OK]クリックします。

     

    今すぐアプリケーションを実行してください。これでCySmartドングルを認識できるはずです。