Updating PSoC Programmer and PSoC Creator Software Offline - KBA228609

Version 7

    Author: RakshithM_16      Version: **

    Do the following to update PSoC® Programmer™ and PSoC Creator™ in a PC which is not directly connected to the internet. The article outlines the procedures to be followed assuming that another PC has access to internet and the downloaded files could be transferred to the PC where the update is required.

     

         1) To update PSoC Programmer:

      1. Download the setup file for the latest version of PSoC Programmer on a computer having access to the internet.
      2. Transfer the file to the required computer.
      3. Run the setup file to install it.
      4. The installer will detect the previous version of PSoC Programmer and will give you an option to update PSoC Programmer.

     

         2) To update PSoC Creator:

    Use the same process to update PSoC Creator.

    Note:

    Code examples in the latest versions of PSoC Creator should be downloaded and will not be available during the time of the installation. Cypress releases minor updates for components, releases new components, and adds support for new devices from time to time, which will not be available without internet access.

    You can find the latest version of PSoC Creator here – PSoC Creator

     

     

    1. To update Peripheral Driver Library:

      1. Download the latest version of Peripheral Driver Library and transfer it to the PC in the same way as described above and run the installer.
      2. On PSoC Creator, select Tools > Options. Update the ‘PDL location’ with the installation directory of the updated PDL.

      

    2. To update components:

    a. Open PSoC Creator in another system connected to the internet.

    b. Select Tools > Find new components’. Select and install all devices.
              These components files are present in the following directory –

         Documents\PSoC Creator\4.2\Downloads ( 4.2).cylib\
    c. Copy the necessary Components to the same folder in the standalone system. The copied components can now be used in PSoC Creator.

    3. To import a Code Example project:

    a. Open PSoC Creator in another PC connected to the internet.

    b. Select File > Code Example. Click the globe icon to download the required code example.
          The selected code example is downloaded into the following directory:
           Documents\PSoC Creator\4.2\Examples\

    c. Copy the required code example folder to the same folder in the standalone system.
    The code example will now be present in the standalone system. Select File > Code Example to use the required code example, and then click Create Project.

             

                 You can also download the code example directly as a project and then copy it to the standalone computer.