Unable to Program PSoC 6 with WICED 6.1 - KBA223414

Version: **

 

Question:

I am unable to program a PSoC 6 device using WICED 6.1. What can I do?

 

Answer:

This is a known issue in the implementation of OpenOCD for PSoC 6 in WICED 6.1. This issue will be fixed in the next release (WICED 6.2). In the interval before the release of WICED 6.2, the OpenOCD files can be replaced with the files attached to this article. Follow these steps:

  1. Close WICED 6.1.
  2. In the install directory of WICED 6.1, go to \WICED-Studio-6.1\43xxx_Wi-Fi\tools\. Copy the OpenOCD folder and paste it to another location. This is to save the original OpenOCD files in case it is corrupted during this process.
  3. Download and unzip the OpenOCD directory attached to this article.
  4. Replace the OpenOCD folder at \WICED-Studio-6.1\43xxx_Wi-Fi\tools\ with the one just downloaded.
  5. Open WICED 6.1 and ensure you can program the PSoC 6 device now.

 

The issue is tracked internally at Cypress by SWWICED-9635.