Unable to program CY8C27x43 devices using PSoC Programmer

Question: My new CY8C27x43 devices won't program in PSoC Programmer.  It says there was a Silicon ID Mismatch.  What do I do?

 

Answer:

Update to the latest build of PSoC Programmer (3.10.1 or later), this will fix the issue.  ("Newer" is relative to the end of 2009)