Mandatory upgrade required for PSoC® Creator™ 1.0 Service Pack 2

Question: Why do I get an error for upgrading to CY_BOOT v2.21 when I open my project in PSoC Creator 1.0 SP2?

 

Answer:

PSoC® Creator™ 1.0 Service Pack 2 is a mandatory update to version 1.0 Production and Service Pack 1. Service Pack 2 is a complete superset of Service Pack 1.

All versions of PSoC3 Application Note projects and code example designed with PSoC Creator 1.0, with device silicon as ‘Production / ES3’ when opened in PSoC Creator Service Pack 2 will generate an error message. This is to enforce the user to update to v2.21 of CY_BOOT.

When a project originally designed using PSoC® Creator™ 1.0 is opened with PSoC® Creator™ 1.0 Service Pack 2 (SP2), the following screen would appear prompting the user for an upgrade. Select the “Yes” option here. This would update the CY_BOOT to v2.21.
 

 

Link for downloading PSoC® Creator™ 1.0 Service Pack 2 (SP2):  http://www.cypress.com/?rID=39551

To learn more details on error fixes and new feature set, refer to release notes