Error in Opening a Project Created in PSoC® Designer™ 5.1 Service Pack 2 after Installing an Emergency Patch - KBA83285

Version: **

 

Question: Why can I not open a project created using PSoC® Designer™ (PD) 5.1 Service Pack (SP) 2 after installing the PD 5.1 SP2 emergency patch?

 

Answer:

 

Problem

After installing PD 5.1 SP2 emergency patch using the procedure mentioned in Installation Hang while installing PSoC Designer 5.1 SP2, an error message is issued by PSoC Designer:

"This project was designed using newer versions of PSoC Designer components. – PSoC Designer Content 5.1 2306
Please update your version of PSoC Designer to open this project."

Root cause

PD checks the Windows registry and then compares it with the information stored in project. The problem is that the value for the build number written to the Windows registry by the PD 5.1 SP2 emergency patch is wrong.

Workaround

Fix the Windows registry

There are two batch files attached.

Run "Rm-PSocDesignerRegKeysPD5.1SP2Hotfix_x64" batch file for 64-bit Windows.

OR

Run "Rm-PSocDesignerRegKeysPD5.1SP2Hotfix_x86" batch file for 32-bit Windows.