CY8CKIT-042-BLE Example Project Does Not Work after Upgrading to PSoC® Creator™ 3.1 Production Release- KBA96325

Version: **

 

Question:

The CY8CKIT-042-BLE Pioneer Kit example projects do not work after I upgrade to PSoC® Creator™ 3.1 Production Release (build 1570).

 

Answer:

 

The CY8CKIT-042-BLE Pioneer Kit has three Cypress BLE devices:

  • CY8C4247LQI-BL483 (CY8CKIT-142 PSoC 4 BLE Module)
  • CYBL10563-56LQXI (CY5671 PRoC BLE Module)
  • CYBL10162-56LQXI (CY5670 CySmart USB Dongle)

PSoC 4 BLE and PRoC BLE are the first BLE devices introduced by Cypress in Nov 2014.

A few customers have observed that some devices fail BLE connectivity tests. Cypress has analyzed the failures and identified that the problem was due to improper manufacturing trim-register settings. A new version of PSoC Creator has been released to correct the trim-register settings, allowing the devices to function as expected. The manufacturing trim-register settings are corrected for all new devices shipped after 01/31/2015. For devices that were shipped previously, Cypress recommends that customers use the latest release of PSoC Creator to ensure all devices function as expected. You can download and install the latest version of PSoC Creator (Version 3.1 Component Pack 1 or later) from http://www.cypress.com/psoccreator.

Some BLE Pioneer Kits use devices from the affected lots; to correct this, a new kit software installer (Rev *A) with PSoC Creator 3.1 Component Pack 1 is available for download from http://www.cypress.com/?rid=102636.

After the kit is programmed with the updated example projects using PSoC Creator 3.1 Component Pack 1, the radio failures will be fixed. If problems persist, please contact Cypress technical support at cytechsupport@cypress.com.